Browsers Supported by TattooZen

Sep 30 2012 11:49 AM

Being that TattooZen utilizes new and advancing technologies, there are a few requirements that your device must meet in order to run TattooZen. However, since TattooZen is 100% web-based, those requirements only have to do with the browsers you are running on your device.

Supported Browsers

Chrome Firefox Safari Opera IE iOS Safari Android Opera Mobile
4+ 4+ 4+ 11+ 8+ 6+ 3+ 12+

We're extremely sorry to all of the Netscape Browser lovers.

Tags: System Requirements, Supported Browsers

Add a Comment